MacOSX doesn't have an uninstall utility.
I use the following script to clean up Firebird installs on Leopard.
It should work on Tiger as well.
Would it make sense to include this in the Firebird package, along with a similar script for earlier versions of MacOSX (pre 10.4 for the powerpc builds)
#!/bin/sh
echo "Clean Services"
echo "Clean User"
dscl localhost -delete /Local/Default/Users/firebird
echo "Clean Group"
dscl localhost -delete /Local/Default/Groups/firebird
if [ -f "/Library/StartupItems/Firebird" ]; then
echo "Remove SuperServer StartupItem"
rm -fr /Library/StartupItems/Firebird
fi
if [ -f "/Library/LaunchDaemons/org.firebird.gds.plist" ]; then
echo "Remove Launchd"
launchctl unload /Library/LaunchDaemons/org.firebird.gds.plist
rm /Library/LaunchDaemons/org.firebird.gds.plist
fi
echo "Remove Framework"
rm -fr /Library/Frameworks/Firebird.framework
echo "Remove Receipt"
rm -fr /Library/Receipts/Firebird*.pkg
#Add the following for Firebird V2.5
echo "Remove /tmp/firebird"
rm -fr /tmp/firebird
Thursday, February 21, 2008
Subscribe to:
Post Comments (Atom)
14 comments:
Thank you for this script. I just spent an hour trying to figure out how to uninstall 2.1 so I can downgrade to 1.5.
So obviously I think that this should definitely be included in the Firebird package.
Thanks!
thank you. Same for me. I need Version 1.5 for an existing database which i cannot migrate right now.
Thank you so much for a very useful script. It seemed to work fine for me on Leopard.
Thank you very much for sharing this useful script.
Thanks for the script.
My Blog
Merci beaucoup!
thx! hope it deletes the complete installation of FB2.5@Mac10.6.6
Thank you so much for a very useful script!
I found it!
Paul. I've trying to remove Firebird 2.5.2 The Firebird removal script is not working for me. I'm very new to the Terminal. I did add sudo before the script.
The terminal spits back "Permission denied" after every command.
Can you recommend a Terminal guide, or let me know what I might be doing wrong. Thanks.
John,
I personally always run it like this.
su (and login as root)
cd to where the script is located
./runthescript.sh
Thank you Paul. I'll try this.
This worked for me on Mac OS Lion. Had to initially login as su using:
sudo su
and authenticate using my usual password. Then finally:
sh uninstall.sh
executing properly! Thanks Sorli...
Thank you, this was helpful! 8-)
Surprisingly seems to have worked perfectly on macOS Monterey as well
Post a Comment